wp updates 1

WordPress ends support for PHP versions below 5.6

Davor 03/23/2019

WordPress has officially ended support for PHP 5.2 – 5.5 and bumped its minimum required PHP version to 5.6.

The plan announced last December was to bump the minimum required version in early 2019 and, depending on the results, bump it again to PHP 7 in December 2019.

Only 2% of WordPress sites remain on PHP 5.2. Roughly 20% are on versions PHP 5.5 or earlier. Nearly half of WordPress installs are on PHP 7.0+.

One might wonder why WordPress’ approach isn’t to just bump it all the way up to PHP 7. With its influence and dominant market share, this requirement would inevitably force users to get on board. However, WordPress contributors believe in supporting users who, for whatever reason, need more help upgrading PHP. Steamrolling this requirement has not been the WordPress way, despite years of immense pressure from the developer community.

“Leaving users behind for technical reasons creates a two-folded web with only few being able to leverage its power,” WordPress Core Committer Felix Arntz said. “Collaborating with and supporting these users gives that power to everyone in the long run.”

WordPress developers around the web sent out celebration tweets after the news was announced. Although PHP 5.6 is the new minimum required version for running WordPress, the project’s technical requirements page recommends users ask their hosts for PHP version 7.3 or greater. PHP 7+ offers massive performance gains for users and developers will be able to update their plugins to use more modern syntax.

Davor Veselinović

I'm Davor, founder of Worda Themes. Working as a Full Stack Developer with more than a decade of experience with WordPress. I build themes and plugins and enjoy writing useful blog posts and share my ideas with others.

Leave a Reply

Your email address will not be published. Required fields are marked *